HTTP Could Not Register URL

Jun 13, 2010 at 10:39 AM
Edited Jun 13, 2010 at 10:40 AM

Hi,

When I run the Server project, I get the following error in the console window that comes up:

"HTTP could not register URL http://+:9999/SyncService/.  Your process does not have access right to this namespace."

I visited the recommended site but I am not sure what tools I need to run to make this work.  I am using Vista.

I tried running the following command line, but it did not fix the problem:

netsh http add urlacl url=http://+:9999/SyncService user=MacBook\user

I tried using the IP 10.0.2.15 as shown in the example. 

Can anyone help me through this?

 

Thanks,

Eebel

Coordinator
Jun 15, 2010 at 12:50 PM
Hello, Please, check out following links: http://blogs.msdn.com/b/paulwh/archive/2007/05/04/addressaccessdeniedexception-http-could-not-register-url-http-8080.aspx http://mark.michaelis.net/Blog/WindowsCommunicationFoundationWithWindowsVistaAndUAC.aspx if it does not help you please let me know and drop here your systems configuration.... Cheers,
Jun 16, 2010 at 12:21 PM

jtorres,

Thanks for the quick reply.  I was able to use the tool from the msdn link to configure the URL.  Now, I just need to figure out how to deploy this so my users don't have to run through this exercise.

Thanks,

Eebel